【PHP】指定されたモジュールが見つかりません。とか言われる

PHP/指定されたモジュールが見つかりません。エラー

PHPの拡張を有効にした後、必要なdllをextの下に入れたのに、「指定されたモジュールが見つかりません。」とか言われる。

原因

同名のdllファイルでも、プラットフォーム(32bitとか64bit)やバージョンが合ってないと、見つけてもらえない。

PHP/有効なWin32アプリケーションではありませんエラー

違うdll使ってると、他に「~は有効な Win32 アプリケーションではありません。」とかも言われる。

同じ名前だからいけるはず!ではなく、きちんとバージョン合わせたファイルを持ってこよう。

投稿者: Output48

中学生の時に初めてHTMLに触れてからホームページ制作を独学で始める。 ベンチャー企業の営業、大手企業のPG・SEを経て、独立。 現在はとある企業のCTOと、変な名前の会社の社長をしてる。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください