Huge IT Lightbox 使用で、SSL警告が出る場合の対処

「この接続は安全ではありません」ポップアップ

どのタイミングか分からないけど、SSL警告が出るようになってたので、対処方法をメモ。

SSL警告の原因は?

Firefox開発ツールで混在コンテンツの警告画面

開発ツールで確認すると、Lightboxで使用している画像に「http://」から始まるコンテンツが検知されてた。

Lightboxプラグインを修正

使用していたプラグインは、「Huge IT Lightbox」。

ソースを確認していくと、どうやらWordPress提供関数である、plugins_url()関数の取得値で、「http://」から始まる場合があるみたい。

どこを修正してもいいんだけど、今回はプラグインのソースで対応してみた。

以下のようにプラグインソースを修正。

変更前:
function hugeit_lightbox_plugins_url() {
  return plugins_url( '', __FILE__ );
}

  ↓

変更後:
function hugeit_lightbox_plugins_url() {
  $ret = plugins_url( '', __FILE__ );
  $ret = str_replace('http://', '//',$ret);
  return $ret;
}

すさまじく無理矢理だけど、これで警告は出なくなったので、とりあえずOK。

追記
この記事書いてから2回ほどアップデートされてるけど同じことになる…。
プラグインのせいじゃなくて、WordPressのせいかな。

投稿者: Output48

中学生の時に初めてHTMLに触れてからホームページ制作を独学で始める。 ベンチャー企業の営業、大手企業のSEを経て、独立。 ここ数年はWEB以外の仕事をしていたため、割と本気で勉強中。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です